You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-cluster/resource-agents/files/3.9.4-configure.patch

31 lines
1.0 KiB

--- a/configure.ac 2013-01-18 13:14:54.492191322 +0100
+++ b/configure.ac 2013-01-18 13:17:17.559551891 +0100
@@ -557,11 +557,13 @@
AC_DEFINE_UNQUOTED(POWEROFF_CMD, "$POWEROFF_CMD", path to the poweroff command)
AC_DEFINE_UNQUOTED(POWEROFF_OPTIONS, "$POWEROFF_OPTIONS", poweroff options)
-AC_PATH_PROGS(XSLTPROC, xsltproc)
-AM_CONDITIONAL(BUILD_DOC, test "x$XSLTPROC" != "x" )
-if test "x$XSLTPROC" = "x"; then
- AC_MSG_WARN([xsltproc not installed, unable to (re-)build manual pages])
-fi
+AC_ARG_ENABLE([doc],
+ AS_HELP_STRING([--enable-doc],[Build documentation]))
+
+AS_IF([test "x$enable_doc" = "xyes"], [
+ AC_PATH_PROGS(XSLTPROC, xsltproc)
+])
+AM_CONDITIONAL([BUILD_DOC], [test "x$enable_doc" = "xyes"] )
AC_SUBST(XSLTPROC)
AC_PATH_PROGS(POD2MAN, pod2man)
@@ -732,8 +734,6 @@
CFLAGS="$CFLAGS -g"
enable_fatal_warnings=no
else
- CFLAGS="$CFLAGS -ggdb3"
-
# We had to eliminate -Wnested-externs because of libtool changes
# Also remove -Waggregate-return because we use one libnet
# call which returns a struct