You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/gtksourceview/files/4.8.1-build-ensure-access-t...

58 lines
1.6 KiB

From 9bea9d1c4a56310701717bb106c52a5324ee392a Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Sun, 7 Mar 2021 08:54:15 -0800
Subject: [PATCH] build: ensure access to resources in corelib build
This should help with some transient build failures in dependent projects.
---
gtksourceview/meson.build | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/gtksourceview/meson.build b/gtksourceview/meson.build
index fd080a9c..b6192604 100644
--- a/gtksourceview/meson.build
+++ b/gtksourceview/meson.build
@@ -172,12 +172,18 @@ gtksourceversion_h = configure_file(
install_dir: join_paths(pkgincludedir, 'gtksourceview'),
)
+gtksource_res = gnome.compile_resources(
+ 'gtksourceview-gresources',
+ 'gtksourceview.gresource.xml'
+)
+
core_sources = [
core_public_c,
core_private_c,
core_enums,
gtksourceversion_h,
core_marshallers,
+ gtksource_res,
]
install_headers(
@@ -216,11 +222,6 @@ extra_public_sources = []
subdir('completion-providers')
-gtksource_res = gnome.compile_resources(
- 'gtksourceview-gresources',
- 'gtksourceview.gresource.xml'
-)
-
# We can't use the static libs on Visual Studio builds
# to form our DLL here directly, so we must use
@@ -233,7 +234,7 @@ foreach int_lib : gtksource_libs
gtksource_objs += int_lib.extract_all_objects()
endforeach
-gtksource_lib = shared_library(package_string, gtksource_res,
+gtksource_lib = shared_library(package_string,
version: lib_version,
darwin_versions: lib_osx_version,
include_directories: gtksourceview_include_dirs,
--
2.26.3