You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/quilt/files/quilt-0.50-no-graphviz.patch

48 lines
1.4 KiB

Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
SRC += $(QUILT_SRC:%=quilt/%)
DIRT += $(QUILT_IN:%=quilt/%)
-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
- remove-trailing-ws
+SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
SCRIPTS := $(SCRIPTS_IN)
Index: b/bash_completion
===================================================================
--- a/bash_completion
+++ b/bash_completion
@@ -95,7 +95,7 @@ _quilt_completion()
prev=${COMP_WORDS[COMP_CWORD-1]}
# quilt sub commands
- cmds='add annotate applied delete diff edit files fold fork graph \
+ cmds='add annotate applied delete diff edit files fold fork \
grep header import mail new next patches pop previous push refresh \
remove rename revert series setup snapshot top unapplied'
@@ -189,19 +189,6 @@ _quilt_completion()
;;
esac
;;
- graph)
- case $prev in
- -T)
- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
- ;;
- --edge-labels)
- COMPREPLY=( $( compgen -W "files" -- $cur ) )
- ;;
- *)
- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
- ;;
- esac
- ;;
grep)
_longopt grep
COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )