You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/rpm/files/rpm-4.16.0-libdir.patch

35 lines
1.1 KiB

diff -uNr rpm-4.16.0.ORIG/configure.ac rpm-4.16.0/configure.ac
--- rpm-4.16.0.ORIG/configure.ac 2020-10-01 11:08:43.780842602 +0100
+++ rpm-4.16.0/configure.ac 2020-10-01 11:09:03.533705353 +0100
@@ -935,13 +935,7 @@
AC_DEFINE_UNQUOTED([RUNDIR],["${RUNDIR}"],[run-time variable directory])
AC_SUBST(RUNDIR)
-if test X"$prefix" = XNONE ; then
- usrprefix="$ac_default_prefix"
-else
- usrprefix=$prefix
-fi
-
-RPMCONFIGDIR="`echo ${usrprefix}/lib/rpm`"
+RPMCONFIGDIR="`echo ${libexecdir}/rpm/`"
AC_SUBST(RPMCONFIGDIR)
AC_SUBST(OBJDUMP)
diff -uNr rpm-4.16.0.ORIG/rpm.am rpm-4.16.0/rpm.am
--- rpm-4.16.0.ORIG/rpm.am 2020-10-01 11:08:43.743842859 +0100
+++ rpm-4.16.0/rpm.am 2020-10-01 11:09:03.533705353 +0100
@@ -1,10 +1,8 @@
# Internal binaries
-## HACK: It probably should be $(libexecdir)/rpm or $(libdir)/rpm
-rpmlibexecdir = $(prefix)/lib/rpm
+rpmlibexecdir = $(pkglibexecdir)
# Host independent config files
-## HACK: it probably should be $(datadir)/rpm
-rpmconfigdir = $(prefix)/lib/rpm
+rpmconfigdir = $(pkglibexecdir)
# Libtool version (current-revision-age) for all our libraries
rpm_version_info = 10:0:1