You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-shells/fish/files/fish-2.5.0-honor-linguas.patch

33 lines
1013 B

diff --git a/Makefile.in b/Makefile.in
index 35e63ae..b73c612 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -195,11 +195,16 @@ ifeq ($(shell uname), Darwin)
endif
#
-# All translation message catalogs
+# All translation message catalogs, filter files based on LINGUAS.
#
TRANSLATIONS_SRC := $(wildcard po/*.po)
-ifdef HAVE_GETTEXT
+ifeq ($(HAVE_GETTEXT), 1)
TRANSLATIONS := $(TRANSLATIONS_SRC:.po=.gmo)
+ifdef LINGUAS
+ TRANSLATIONS_ALL := $(TRANSLATIONS)
+ TRANSLATIONS_WANTED = $(patsubst %,po/%.gmo,$(LINGUAS))
+ TRANSLATIONS = $(filter $(TRANSLATIONS_WANTED),$(TRANSLATIONS_ALL))
+endif
else
TRANSLATIONS :=
endif
@@ -764,7 +769,7 @@ uninstall: uninstall-translations | show-prefix show-bindir show-sysconfdir show
.PHONY: uninstall
install-translations: $(TRANSLATIONS) | show-HAVE_GETTEXT
-ifdef HAVE_GETTEXT
+ifeq ($(HAVE_GETTEXT), 1)
@echo "Installing translations..."
$v for i in $(TRANSLATIONS); do \
$(INSTALL) -m 755 -d $(DESTDIR)$(localedir)/`basename $$i .gmo`/LC_MESSAGES; \