You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/dvorak7min/files/dvorak7min-1.6.1-ncurses-pk...

25 lines
668 B

https://bugs.gentoo.org/show_bug.cgi?id=722336
https://bugs.gentoo.org/show_bug.cgi?id=689986
https://bugs.gentoo.org/show_bug.cgi?id=698082
https://bugs.gentoo.org/show_bug.cgi?id=702372
diff --git a/Makefile b/Makefile
index e0e7645..6aee6ab 100644
--- a/Makefile
+++ b/Makefile
@@ -15,12 +15,13 @@ LIMIT_LENGTH = -DLIMIT_LENGTH=1024
### That's all ###
-CC = gcc
+PKG_CONFIG ?= pkg-config
+CC ?= gcc
CFLAGS += -Wall \
$(PRETTINESS) $(NASTINESS) $(BEEPS) $(FLASHES) $(COLORS) \
$(LIMIT_LENGTH) $(PROF)
LDFLAGS += $(PROF)
-LIBS = -lncurses
+LIBS = $(shell pkg-config --libs ncurses)
OBJECTS = dvorak7min.o lessons.o
HEADERS = lessons.h