You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/scons/files/scons-2.1.0-jython.patch

14 lines
427 B

http://scons.tigris.org/issues/show_bug.cgi?id=2791
--- setup.py
+++ setup.py
@@ -325,7 +325,7 @@
self.copy_scons(src, scons_version_bat)
# --- distutils copy/paste ---
- if os.name == 'posix':
+ if hasattr(os, 'chmod'):
# Set the executable bits (owner, group, and world) on
# all the scripts we just installed.
for file in self.get_outputs():