You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/xpra/files/xpra-1.0.1-cflags-param.patch

18 lines
558 B

--- xpra-1.0.1/setup.py
+++ xpra-1.0.1/setup.py
@@ -696,7 +696,14 @@
for s in (pkg_config_out, env_cflags, env_ldflags):
if not s:
continue
+ ahead = False
for token in s.split():
+ if token == '--param':
+ ahead = True
+ continue
+ if ahead:
+ ahead = False
+ continue
if token[:2] in ignored_flags:
pass
elif token[:2] in flag_map: