You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/pms/files/pms-9999-fix-automagic-dep....

35 lines
1.1 KiB

From 3771a139059cf248cc07cf8a735c0cd95ae3c6af Mon Sep 17 00:00:00 2001
From: Mykyta Holubakha <hilobakho@gmail.com>
Date: Fri, 9 Sep 2016 00:56:22 +0300
Subject: [PATCH] Fix automagic pandoc dependency
---
configure.ac | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 45e6d1a..aea9285 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,9 +25,14 @@ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.0],, [AC_MSG_ERROR([glib 2.0 or newer i
PKG_CHECK_MODULES([libmpdclient], [libmpdclient >= 2.5],, [AC_MSG_ERROR([libmpdclient 2.5 or newer is required])])
# Check for Pandoc
-AC_PATH_PROG(PANDOC,pandoc,no)
-if [[ "x$PANDOC" = xno ]]; then
- AC_MSG_WARN([The manual page will not be built.])
+AC_ARG_WITH([doc], AS_HELP_STRING([--with-doc],[Build the manpage (default: disabled)]))
+if [test "x$with_doc" = "xyes"]; then
+ AC_PATH_PROG(PANDOC,pandoc,no)
+ if [[ "x$PANDOC" = xno ]]; then
+ AC_MSG_WARN([The manual page will not be built.])
+ fi
+else
+ PANDOC="no"
fi
AM_CONDITIONAL([PANDOC], [test "x$PANDOC" != xno])
--
2.10.0