You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.p...

37 lines
1.1 KiB

configure.ac | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index b8a0b9b..b0a4635 100755
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ AC_PROG_AWK
AC_PROG_CXX
AC_PROG_CC
AC_PROG_MAKE_SET
+AM_PROG_AR
AC_PROG_RANLIB
AC_PROG_INSTALL
AM_PATH_PYTHON([2.4])
@@ -54,7 +55,7 @@ AC_CANONICAL_HOST
# set CFLAGS and CXXFLAGS
user_CFLAGS=${CFLAGS}
-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
+generic_CFLAGS="-Wall -Wno-strict-aliasing -Wuninitialized"
ext_CFLAGS=""
debug_CFLAGS=""
#echo "${host_cpu}-${host_os}"
@@ -99,9 +100,9 @@ AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling with
[ext_LDFLAGS="-lprofiler -ltcmalloc"], [])
CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS} ${OPENMP_CFLAGS}"
-CXXFLAGS="$CFLAGS"
+CXXFLAGS="$CXXFLAGS"
CXXFLAGS="$CXXFLAGS $BOOST_CPPFLAGS $BAM_CPPFLAGS"
-LDFLAGS="$ext_LDFLAGS"
+LDFLAGS="$LDFLAGS $ext_LDFLAGS"
# Checks for structures/functions that can be used to determine system memory
AC_CHECK_MEMBERS([struct sysinfo.totalram], [], [], [#include <sys/sysinfo.h>])