You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/apvlv/files/apvlv-0.1.5-cflags.patch

21 lines
702 B

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ae9ae09..5831e7a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,13 +1,11 @@
IF (WIN32)
ADD_DEFINITIONS (-D_CRT_SECURE_NO_WARNINGS)
ELSE (WIN32)
- SET (CMAKE_CXX_FLAGS "-Wall -fno-strict-aliasing")
+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fno-strict-aliasing")
OPTION (APVLV_ENABLE_DEBUG "If build binary with debug infomations." OFF)
IF (APVLV_ENABLE_DEBUG)
- SET (CMAKE_CXX_FLAGS "-D_DEBUG -g ${CMAKE_CXX_FLAGS}")
- ELSE (APVLV_ENABLE_DEBUG)
- SET (CMAKE_CXX_FLAGS "-O2 ${CMAKE_CXX_FLAGS}")
+ SET (CMAKE_CXX_FLAGS "-D_DEBUG ${CMAKE_CXX_FLAGS}")
ENDIF (APVLV_ENABLE_DEBUG)
ENDIF (WIN32)