You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-editors/wxhexeditor/files/wxhexeditor-0.22-makefile.p...

97 lines
2.7 KiB

Makefile | 19 +++++--------------
src/HexDialogs.cpp | 2 +-
src/HexEditor.h | 2 +-
src/HexPanels.h | 2 +-
4 files changed, 8 insertions(+), 17 deletions(-)
diff --git a/Makefile b/Makefile
index ead0702..cb80ddf 100755
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
WXCONFIG = wx-config
CC = `$(WXCONFIG) --cc`
CXX = `$(WXCONFIG) --cxx`
-CFLAGS = -O2
-CXXFLAGS = -O2
-WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -Imhash/include -MMD -O2 -c ${OPTFLAGS}
+CFLAGS ?= -O2
+CXXFLAGS ?= -O2
+WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -O2 -c ${OPTFLAGS}
WXLDFLAGS = `$(WXCONFIG) --libs`
RC = `$(WXCONFIG) --rescomp`
#RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
@@ -23,7 +23,7 @@ SOURCES= src/HexEditorGui.cpp \
src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
src/HexEditorCtrl/HexEditorCtrlGui.cpp\
src/HexEditorFrame.cpp
-LIBS = udis86/libudis86/.libs/libudis86.a mhash/lib/.libs/libmhash.a
+LIBS = -ludis86 -lmhash
OBJECTS=$(SOURCES:.cpp=.o)
DEPENDS=$(OBJECTS:.o=.d)
LANGUAGEDIRS=tr ru
@@ -34,7 +34,7 @@ EXECUTABLE=wxHexEditor
EXECUTABLE_WIN=$(EXECUTABLE).exe
EXECUTABLE_DIR_MAC=$(EXECUTABLE).app
-PREFIX = /usr/local
+PREFIX = /usr
BINDIR = $(PREFIX)/bin
DATADIR = $(PREFIX)/share
LOCALEDIR = $(DATADIR)/locale
@@ -61,15 +61,6 @@ langs: $(MOBJECTS)
%.mo : %.po
$(MSGFMT) $< -o $@
-udis86/libudis86/.libs/libudis86.a:
- cd udis86;./autogen.sh
- cd udis86;./configure --host=$(HOST) CC=$(CC) CXX=$(CXX) CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
- cd udis86/libudis86; $(MAKE) $(MFLAGS)
-
-mhash/lib/.libs/libmhash.a:
- cd mhash; ./configure --host=$(HOST) CC=$(CC) CXX=$(CXX) CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
- cd mhash; $(MAKE) $(MFLAGS)
-
win: $(RESOURCES) $(EXECUTABLE_WIN)
#Stack override required for file comparison function...
diff --git a/src/HexDialogs.cpp b/src/HexDialogs.cpp
index 133830e..6ea0cc0 100644
--- a/src/HexDialogs.cpp
+++ b/src/HexDialogs.cpp
@@ -24,7 +24,7 @@
#define NANINT 0xFFFFFFFFFFFFFFFFLL
#include "HexDialogs.h"
#include <wx/progdlg.h>
-#include "../mhash/include/mhash.h"
+#include <mhash.h>
#ifdef _OPENMP
#include <omp.h>
diff --git a/src/HexEditor.h b/src/HexEditor.h
index 7946d05..d4e1eb8 100644
--- a/src/HexEditor.h
+++ b/src/HexEditor.h
@@ -25,7 +25,7 @@
#ifndef _wxHexEditor_h_
#define _wxHexEditor_h_
-#include "../mhash/include/mhash.h"
+#include <mhash.h>
#include <wx/ffile.h>
#include <wx/clipbrd.h>
diff --git a/src/HexPanels.h b/src/HexPanels.h
index d498fa9..9f2ad5d 100644
--- a/src/HexPanels.h
+++ b/src/HexPanels.h
@@ -27,7 +27,7 @@
#include "HexEditorFrame.h"
#include "HexEditorCtrl/HexEditorCtrl.h"
#include "HexEditorCtrl/wxHexCtrl/wxHexCtrl.h"
-#include "../udis86/udis86.h"
+#include <udis86.h>
#ifdef WX_GCH
#include <wx_pch.h>