You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/glcdprocdriver/files/glcdprocdriver-0.0.3-makefi...

23 lines
525 B

--- ./Makefile 2006-10-05 08:37:03.000000000 +0000
+++ ./Makefile 2007-04-07 19:06:00.000000000 +0000
@@ -11,6 +11,8 @@
PACKAGE = $(ARCHIVE)
TMPDIR = /tmp
+LIBS=-lglcddrivers -lglcdgraphics
+
LIBNAME = libglcdprocdriver.so
SONAME = $(LIBNAME).1
@@ -24,6 +26,9 @@
all: $(LIBNAME)
+$(OBJS): %.o: %.c
+ $(CXX) -c -fPIC $(CXXFLAGS) $< -o $@
+
$(LIBNAME): $(OBJS)
- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -Wl,-soname="$(SONAME)" -o $@
+ $(CXX) $(LDFLAGS) -shared $(OBJS) $(LIBS) -Wl,-soname="$(SONAME)" -o $@