You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/rwhoisd/files/rwhoisd-destdir-1.5.9.5.patch

40 lines
1007 B

--- a/tools/rwhois_repack/Makefile.in
+++ b/tools/rwhois_repack/Makefile.in
@@ -52,9 +52,9 @@
# procedural
install:
- if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
- $(INSTALL) rwhois_repack $(bindir)
+ if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir $(DESTDIR)$(exec_prefix); fi
+ if [ ! -d $(DESTDIR)$(bindir) ]; then mkdir $(DESTDIR)$(bindir); fi
+ $(INSTALL) rwhois_repack $(DESTDIR)$(bindir)
uninstall:
$(RM) $(bindir)/rwhois_repack
--- a/sample.data/Makefile.in
+++ b/sample.data/Makefile.in
@@ -10,7 +10,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = $(exec_prefix)/bin
-etcdir = $(exec_prefix)/etc
+etcdir = /etc
srcdir = @srcdir@
VPATH = @srcdir@
--- a/sample.data/Makefile.in
+++ b/sample.data/Makefile.in
@@ -17,7 +17,7 @@
DESTDIR =
-RWHOIS_ROOT_DIR = $(DESTDIR)$(etcdir)/rwhoisd/samples
+RWHOIS_ROOT_DIR = $(DESTDIR)/var/rwhoisd/samples
FILES = \
a.com \