You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-block/lio-utils/files/snmp-makefile.patch

23 lines
615 B

--- mib-modules/Makefile.old 2011-06-21 00:26:30.000000000 +0400
+++ mib-modules/Makefile 2011-06-21 00:29:28.000000000 +0400
@@ -18,8 +18,8 @@
iscsiAuthData.o
CC = gcc
-CFLAGS = -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC
-CFLAGS += -I../include -Wall -Werror
+INCLUDES = -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup
+INCLUDES += -I../include
#CFLAGS +=$(AUTO_CFLAGS)
LD = gcc -shared
@@ -29,7 +29,7 @@
all: $(TARG)
%.o: %.c *.h
- $(CC) $(CFLAGS) -o $@ -c $<
+ $(CC) -fPIC $(INCLUDES) $(CFLAGS) -o $@ -c $<
$(TARG): $(OBJS)
$(LD) -o $@ $(OBJS)