You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-libs/libcap/files/libcap-2.25-gperf.patch

21 lines
620 B

update gperf call to work with gperf-3.1
https://bugs.gentoo.org/604802
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -44,11 +44,12 @@
./_makenames > cap_names.h
$(GPERF_OUTPUT): cap_names.list.h
- (printf "%b" "struct __cap_token_s { const char *name; int index; };\n%{\nconst struct __cap_token_s *__cap_lookup_name(const char *, unsigned int);\n%}\n%%\n"; \
+ (printf "%b" "struct __cap_token_s { const char *name; int index; };\n%%\n"; \
$(SED) -e 's:["{}]::g' -e 's:,$$::' $<) | \
gperf \
--ignore-case \
--language=ANSI-C \
+ --includes \
--readonly \
--null-strings \
--global-table \