You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-tv/kodi/files/kodi-9999-no-arm-flags.patch

17 lines
478 B

http://bugs.gentoo.org/400617
do not force any particular ABI or FPU or SIMD compiler flags for arm
targets. let the toolchain and user CFLAGS control that.
--- a/configure.in
+++ b/configure.in
@@ -571,7 +571,7 @@
elif test "$target_platform" = "target_raspberry_pi"; then
ARCH="arm"
use_arch="arm"
-elif test "$use_arch" = "arm"; then
+elif false; then
CFLAGS="$CFLAGS -mno-apcs-stack-check"
CXXFLAGS="$CXXFLAGS -mno-apcs-stack-check"
FFMPEG_EXTRACFLAGS=""