You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost...

25 lines
950 B

From 36b73da8958927f975b3d01a062aa6c0e149d97f Mon Sep 17 00:00:00 2001
From: Peter Thorson <git@zaphoyd.com>
Date: Mon, 27 Apr 2020 10:34:06 -0500
Subject: [PATCH] [cmake] Remove quotes that was making it hard for cmake to
find newer boost versions. fixes #855
---
CMakeLists.txt | 2 +-
changelog.md | 3 +++
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e9c80e84..ffcd8583b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
set (Boost_USE_MULTITHREADED TRUE)
set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
+ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
if (Boost_FOUND)
# Boost is a project wide global dependency.