You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/NativeThread/files/Makefile.patch

23 lines
759 B

--- Makefile 2008-03-03 13:59:06.000000000 +0100
+++ Makefile.new 2008-03-30 16:27:12.000000000 +0200
@@ -1,14 +1,14 @@
-CC = gcc
INC = $(JAVA_HOME)/include
-CFLAGS = -Wall -O3 -fPIC
-LDFLAGS = -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
+CFLAGS += -Wall
+LDFLAGS += -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
LIBS = -lc
all: clean libNativeThread.so
NativeThread.class:
- javac java/NativeThread.java
- mv java/NativeThread.class freenet/support/io/
+ javac -classpath /usr/share/freenet/lib/freenet.jar NativeThread.java
+ mkdir -p freenet/support/io
+ mv NativeThread.class freenet/support/io/
libNativeThread.so: NativeThread.c NativeThread.h
$(CC) $(CFLAGS) -o libNativeThread.so $(LDFLAGS) NativeThread.c $(LIBS)