You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/m2crypto/files/m2crypto-crossdev-0.31.0.patch

13 lines
505 B

--- a/setup.py
+++ b/setup.py
@@ -50,7 +50,8 @@
'*Visual*', 'VC', 'include')
err = glob.glob(globmask)
else:
- pid = subprocess.Popen(['cpp', '-Wp,-v', '-'],
+ pid = subprocess.Popen(os.environ.get('CPP', 'cpp').split() +
+ ['-Wp,-v', '-'],
stdin=open(os.devnull, 'r'),
stdout=subprocess.PIPE,
stderr=subprocess.PIPE)