You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-tex/csindex/files/csindex-2.11c-flags.patch

17 lines
432 B

Index: csindex-19980713/Makefile
===================================================================
--- csindex-19980713.orig/Makefile
+++ csindex-19980713/Makefile
@@ -1,9 +1,9 @@
DEFS=-DOS_SYSV
OBJS=csindex.o genind.o mkind.o qsort.o scanid.o scanst.o sortid.o
-CFLAGS= -O2 $(DEFS)
+CFLAGS+= $(DEFS)
all: csindex
csindex: $(OBJS)
- $(CC) -o csindex $(DEFS) $(OBJS) -lm
+ $(CC) $(LDFLAGS) -o csindex $(DEFS) $(OBJS) -lm