You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libhdhomerun/files/20190621-use_shared_library...

17 lines
524 B

--- /Makefile 2019-09-16 10:18:56.033121543 -0500
+++ /Makefile 2019-09-16 10:14:00.110155153 -0500
@@ -38,10 +38,10 @@
endif
endif
-all : hdhomerun_config$(BINEXT) libhdhomerun$(LIBEXT)
+all : libhdhomerun$(LIBEXT) hdhomerun_config$(BINEXT)
-hdhomerun_config$(BINEXT) : hdhomerun_config.c $(LIBSRCS)
- $(CC) $(CFLAGS) $+ $(LDFLAGS) -o $@
+hdhomerun_config$(BINEXT) : hdhomerun_config.c libhdhomerun$(LIBEXT)
+ $(CC) $(CFLAGS) $+ $(LDFLAGS) -L./ -lhdhomerun -o $@
$(STRIP) $@
libhdhomerun$(LIBEXT) : $(LIBSRCS)