You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/gxine/files/gxine-0.5.907-underlinking....

24 lines
781 B

--- configure.ac
+++ configure.ac
@@ -333,6 +333,20 @@
AC_SUBST(THREAD_LIBS)
dnl ---------------------------------------------
+dnl Check for libdl/libdld for dlopen()
+dnl ---------------------------------------------
+AC_SEARCH_LIBS([dlopen], [dl dld], [], [
+ AC_MSG_ERROR([unable to find the dlopen() function])
+])
+
+dnl ---------------------------------------------
+dnl Check for libm for log10()
+dnl ---------------------------------------------
+AC_SEARCH_LIBS([log10], [m], [], [
+ AC_MSG_ERROR([unable to find the log10() function])
+])
+
+dnl ---------------------------------------------
dnl Check for xine-lib
dnl ---------------------------------------------
AM_PATH_XINE([$XINE_LIB_MIN_VER],, AC_MSG_ERROR([*** Please install xine-lib (devel) first ***]))