You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch

29 lines
1.1 KiB

configure.ac | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 96ffbac..e88b8e4 100755
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,8 @@ AC_CANONICAL_HOST
# set CFLAGS and CXXFLAGS
user_CFLAGS=${CFLAGS}
-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -ftemplate-depth-1024"
+generic_CFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized"
+generic_CXXFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized -ftemplate-depth-1024"
ext_CFLAGS=""
debug_CFLAGS=""
#echo "${host_cpu}-${host_os}"
@@ -106,8 +107,8 @@ AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling with
[ext_LDFLAGS="-lprofiler -ltcmalloc"], [])
CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS} ${OPENMP_CFLAGS}"
-CXXFLAGS="$CFLAGS"
-CXXFLAGS="${CXXFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
+CXXFLAGS="${generic_CFLAGS} ${CXXFLAGS}"
+CPPFLAGS="${CPPFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
user_LDFLAGS="$LDFLAGS"
LDFLAGS="${ext_LDFLAGS} ${user_LDFLAGS}"