You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/spice/files/0.11.0-gold.patch

31 lines
989 B

server/tests/Makefile.am | 2 ++
server/tests/Makefile.in | 2 +-
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
index e77865c..905de9d 100644
--- a/server/tests/Makefile.am
+++ b/server/tests/Makefile.am
@@ -19,6 +19,8 @@ LDADD = \
$(top_builddir)/server/libspice-server.la \
$(NULL)
+AM_LDFLAGS = -pthread
+
COMMON_BASE = \
basic_event_loop.c \
basic_event_loop.h \
diff --git a/server/tests/Makefile.in b/server/tests/Makefile.in
index 5b177e2..3aacfd3 100644
--- a/server/tests/Makefile.in
+++ b/server/tests/Makefile.in
@@ -144,7 +144,7 @@ am__v_at_0 = @
CCLD = $(CC)
LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
+ $(AM_LDFLAGS) $(LDFLAGS) -pthread -o $@
AM_V_CCLD = $(am__v_CCLD_@AM_V@)
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
am__v_CCLD_0 = @echo " CCLD " $@;