You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-base/gnome-control-center/files/gnome-control-center-3.16.0...

45 lines
1.3 KiB

From 95420469407223898564425b7622ac66e7ed70d5 Mon Sep 17 00:00:00 2001
From: Ole Reifschneider <tranquility@gentoo.org>
Date: Sat, 25 Apr 2015 22:22:09 +0200
Subject: [PATCH] Make wayland support optional
---
configure.ac | 21 +++++++++++++++------
1 file changed, 15 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index 9713256..6b34962 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,12 +231,21 @@ if test "x$have_udev" = xyes ; then
fi
AM_CONDITIONAL(HAVE_UDEV, [test "x$have_udev" = "xyes"])
-PKG_CHECK_MODULES(WAYLAND, gdk-wayland-3.0, have_wayland=yes, have_wayland=no)
-if test "x$have_wayland" = xyes ; then
- if test "x$have_udev" != xyes ; then
- AC_MSG_ERROR([udev is required for Wayland support])
- fi
-fi
+AC_ARG_ENABLE(
+ [wayland],
+ AS_HELP_STRING([--disable-wayland], [disable wayland support]),
+ [],
+ enable_wayland=auto
+)
+
+AS_IF([test "$enable_wayland" != "no"],
+ [
+ AS_IF([test "x$have_udev" = xno],
+ [AC_MSG_ERROR([udev is required for Wayland support])],
+ [AC_DEFINE(HAVE_UDEV, 1, [System has udev])])
+
+ PKG_CHECK_MODULES(WAYLAND, gdk-wayland-3.0)
+])
PKG_CHECK_MODULES(NETWORK_MANAGER, NetworkManager >= $NETWORK_MANAGER_REQUIRED_VERSION
libnm-glib >= $NETWORK_MANAGER_REQUIRED_VERSION
--
2.0.5