You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-electronics/magic/files/magic-7.5.231-ldflags.patch

17 lines
426 B

--- magic-7.5.231/scripts/configure.in
+++ magic-7.5.231/scripts/configure.in
@@ -1428,11 +1428,11 @@
;;
*-linux*)
- LDDL_FLAGS='-shared -Wl,-soname,$@'
+ LDDL_FLAGS+=' -shared -Wl,-soname,$@'
if test "x${loader_run_path}" != "x" ; then
LD_RUN_PATH="${LD_RUN_PATH} -Wl,-rpath,${loader_run_path}"
fi
- LDFLAGS=""
+ LDFLAGS+=" "
EXTRA_LIB_SPECS="-ldl"
;;