You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-physics/meep/files/meep-1.2-no-auto-mpb.patch

17 lines
652 B

diff -Nur meep-1.2.orig/configure.ac meep-1.2/configure.ac
--- meep-1.2.orig/configure.ac 2012-08-14 21:52:13.000000000 +0100
+++ meep-1.2/configure.ac 2012-08-14 22:00:55.000000000 +0100
@@ -161,8 +161,10 @@
###########################################################################
# MPB library
-
-AC_CHECK_HEADER(mpb.h, [have_mpb=maybe], [have_mpb=no])
+AC_ARG_WITH(mpb, [AC_HELP_STRING([--without-mpb],[do not build with mpb])], ok=$withval, ok=yes)
+if test "$ok" = "yes"; then
+ AC_CHECK_HEADER(mpb.h, [have_mpb=maybe], [have_mpb=no])
+fi
if test $have_mpb = maybe; then
if test "x$acx_lapack_ok" = x -a "$have_harminv" = xno; then