You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/xinetd/files/xinetd-2.3.14-install-contr...

25 lines
728 B

--- xinetd-2.3.14/Makefile.in
+++ xinetd-2.3.14/Makefile.in
@@ -9,6 +9,7 @@
DESTDIR =
prefix = @prefix@
exec_prefix = @exec_prefix@
+ETCDIR = @sysconfdir@
DAEMONDIR = @sbindir@
MANDIR = @mandir@
topdir = @top_srcdir@
@@ -97,7 +98,12 @@
rm -f $(MANDIR)/man8/xinetd.log.8
rm -f $(MANDIR)/man8/xinetd.8
rm -f $(MANDIR)/man8/itox.8
-
+
+install-contrib:
+ test -d $(DESTDIR)$(ETCDIR)/xinetd.d || mkdir -p $(DESTDIR)$(ETCDIR)/xinetd.d
+ $(INSTALL_CMD) -m 644 contrib/xinetd.conf $(DESTDIR)$(ETCDIR)
+ $(INSTALL_CMD) -m 644 contrib/xinetd.d/* $(DESTDIR)$(ETCDIR)/xinetd.d
+
distclean: clean
rm -f config.cache config.log Makefile config.status xinetd/itox
rm -f config.h @srcdir@/libs/include/* @srcdir@/libs/man/*