You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-apache/mod_python/files/mod_python-3.5.0-buildsyste...

36 lines
1.0 KiB

--- mod_python-3.5.0/scripts/Makefile.in
+++ mod_python-3.5.0/scripts/Makefile.in
@@ -26,4 +26,5 @@
rm -f Makefile
install:
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
$(INSTALL) -m 0755 mod_python $(DESTDIR)$(BINDIR)/mod_python
--- mod_python-3.5.0/dist/Makefile.in
+++ mod_python-3.5.0/dist/Makefile.in
@@ -34,9 +34,9 @@
install_py_lib: mod_python src
@cd src; $(MAKE) psp_parser.c
if test -z "$(DESTDIR)" ; then \
- $(PYTHON_BIN) setup.py install --optimize 2 --force ; \
+ $(PYTHON_BIN) setup.py install --no-compile --force ; \
else \
- $(PYTHON_BIN) setup.py install --optimize 2 --force --root $(DESTDIR) ; \
+ $(PYTHON_BIN) setup.py install --no-compile --force --root $(DESTDIR) ; \
fi
mod_python.so:
--- mod_python-3.5.0/Makefile.in
+++ mod_python-3.5.0/Makefile.in
@@ -31,8 +31,8 @@
dso: @DSO@
do_dso:
- @cd src && $(MAKE)
- @cd dist && $(MAKE) build
+ cd src && $(MAKE)
+ cd dist && $(MAKE) build
@echo
@echo 'Now run sudo make install'
@echo ' (or, if you only want to perform a partial install,'