You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-drivers/xf86-video-nouveau/files/xf86-video-nouveau-1.0.11-g...

43 lines
1.3 KiB

diff -ur a/configure.ac b/configure.ac
--- a/configure.ac 2014-09-03 21:29:04.000000000 +0200
+++ b/configure.ac 2014-10-23 16:31:21.117695404 +0200
@@ -140,17 +140,29 @@
#include "list.h"])
fi
-AC_CHECK_HEADERS([glamor.h],[found_glamor_header=yes],[found_glamor_header=no],
- [#include "xorg-server.h"])
-AC_MSG_CHECKING([whether to include GLAMOR support])
-if test "x$found_glamor_header" = xyes && pkg-config --exists "xorg-server >= 1.15.99.901"
-then
- AC_DEFINE(HAVE_GLAMOR, 1, [Build support for glamor acceleration])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
+AC_ARG_ENABLE(glamor,
+ AS_HELP_STRING([--enable-glamor],
+ [Enable glamor, a new GL-based acceleration [default=auto]]),
+ [GLAMOR="$enableval"],
+ [GLAMOR=auto])
+
+if test "x$GLAMOR" != "xno"; then
+ AC_CHECK_HEADERS([glamor.h],[found_glamor_header=yes],[found_glamor_header=no],
+ [#include "xorg-server.h"])
+ AC_MSG_CHECKING([whether to include GLAMOR support])
+ if test "x$found_glamor_header" = xyes && pkg-config --exists "xorg-server >= 1.15.99.901"
+ then
+ AC_DEFINE(HAVE_GLAMOR, 1, [Build support for glamor acceleration])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ if test "x$GLAMOR" != "xauto"; then
+ AC_MSG_ERROR([failed to find required Xorg headers for glamor])
+ fi
+ fi
fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile