You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-wm/xpra/files/xpra-0.14.0-prefix.patch

28 lines
945 B

--- xpra-0.14.0/xpra/platform/paths.py
+++ xpra-0.14.0/xpra/platform/paths.py
@@ -22,9 +22,9 @@
def get_system_conf_dir():
#the system wide configuration directory
- if sys.prefix == '/usr':
+ if sys.prefix[-4:] == '/usr':
#default posix config location:
- default_conf_dir = '/etc/xpra'
+ default_conf_dir = sys.prefix[:-4] + '/etc/xpra'
else:
#hope the prefix is something like "/usr/local":
default_conf_dir = sys.prefix + '/etc/xpra/'
--- xpra-0.14.0/setup.py
+++ xpra-0.14.0/setup.py
@@ -1470,8 +1470,8 @@
#prepare default [/usr/local]/etc configuration files:
if '--user' in sys.argv:
etc_prefix = 'etc/xpra'
- elif sys.prefix == '/usr':
- etc_prefix = '/etc/xpra'
+ elif sys.prefix[-4:] == '/usr':
+ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
else:
etc_prefix = sys.prefix + '/etc/xpra'