You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/gprolog/files/gprolog-1.4.1-nodocs.patch

30 lines
1.1 KiB

--- gprolog-1.4.1.orig/src/Makefile.in 2012-01-10 18:24:39.000000000 +0100
+++ gprolog-1.4.1/src/Makefile.in 2012-07-02 12:53:42.000000000 +0200
@@ -97,7 +97,7 @@
# --- Documentation --- #
install-doc:
- if test $(DOC_DIR) != none; then \
+ if test $(DOC_DIR) != $(DESTDIR)none; then \
./mkinstalldirs $(DOC_DIR); \
(F=`cd ../doc; echo $(DOC_FILES)`; \
for i in $$F; do $(INSTALL_DATA) ../doc/$$i $(DOC_DIR); done); \
@@ -113,7 +113,7 @@
# --- HTML --- #
install-html:
- if test $(HTML_DIR) != none; then \
+ if test $(HTML_DIR) != $(DESTDIR)none; then \
./mkinstalldirs $(HTML_DIR); \
(F=`cd ../doc/html_node; echo $(HTML_FILES)`; \
for i in $$F; do $(INSTALL_DATA) ../doc/html_node/$$i $(HTML_DIR); done); \
@@ -129,7 +129,7 @@
# --- Examples --- #
install-examples:
- if test $(EXAMPLES_DIR) != none; then \
+ if test $(EXAMPLES_DIR) != $(DESTDIR)none; then \
./mkinstalldirs $(EXAMPLES_DIR)/ExamplesPl; \
(F=`cd ../examples/ExamplesPl; echo $(EXPL_FILES)`; \
for i in $$F; do $(INSTALL_DATA) ../examples/ExamplesPl/$$i $(EXAMPLES_DIR)/ExamplesPl; done); \