You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-laptop/thinkfan/files/thinkfan-0.7.3-makefile.patch

29 lines
825 B

--- thinkfan-0.7.3/Makefile
+++ thinkfan-0.7.3/Makefile
@@ -1,20 +1,12 @@
.DEFAULT_GOAL := thinkfan
-thinkfan: system.o parser.o config.o thinkfan.o message.o
- gcc $(CFLAGS) -Wall -o thinkfan system.o config.o parser.o \
- thinkfan.o message.o
-
-message.o: message.c globaldefs.h
- gcc $(CFLAGS) -Wall -c message.c
+CC ?= gcc
-system.o: system.c system.h message.h globaldefs.h parser.h
- gcc $(CFLAGS) -Wall -c system.c
-
-config.o: config.c config.h message.h globaldefs.h system.h parser.h
- gcc $(CFLAGS) -Wall -c config.c
+thinkfan: system.o parser.o config.o thinkfan.o message.o
+ $(CC) $(LDFLAGS) -Wall -o $@ $^
-thinkfan.o: thinkfan.c thinkfan.h message.h globaldefs.h config.h
- gcc $(CFLAGS) -Wall -c thinkfan.c
+%.o: %.c
+ $(CC) $(CFLAGS) -Wall -c -o $@ $<
clean:
rm -rf *.o thinkfan