You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/openexr_viewers/files/openexr_viewers-2.0.0-nvidi...

15 lines
434 B

--- configure.ac
+++ configure.ac
@@ -192,7 +192,10 @@
dnl
dnl check for Cg
dnl
-if test "${have_fltk}" = yes; then
+AC_ARG_ENABLE(cg, AC_HELP_STRING([--enable-cg],
+ [enable nvidia cg support [[default=check]]]), [want_cg="${enableval}"], [want_cg=yes])
+
+if test "${have_fltk}" = yes -a "${want_cg}" != "no"; then
AM_PATH_CG(have_cg=yes, have_cg=no)
if test "${have_cg}" = yes; then
AC_DEFINE(HAVE_FRAGMENT_SHADERS)