You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/g-wrap/files/glib_automagic.patch

17 lines
559 B

--- configure.ac.old 2007-01-18 17:54:08.000000000 +0100
+++ configure.ac 2007-01-18 17:57:38.000000000 +0100
@@ -119,11 +119,8 @@
AC_SUBST(GW_LANGUAGES)
dnl Check for optional libraries
-AC_CHECK_PROG(have_glib, glib-config, yes, no)
-if test "$have_glib" = yes; then
- PKG_CHECK_MODULES(GLIB, glib, [echo building GLib 1.2 support])
-else
- echo Not building Glib 1.2 support
+if test "x$with_glib" != "xno"; then
+ PKG_CHECK_MODULES([GLIB], [glib-2.0], [have_glib=yes], [have_glib=no])
fi
AM_CONDITIONAL(HAVE_GLIB, test "$have_glib" = yes)