You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/gnat-gpl/files/gnat-gpl-2017-libatomic-Wer...

20 lines
558 B

libatomic does not respect --disable-werror
https://bugs.gentoo.org/475350
--- a/libatomic/configure.ac
+++ b/libatomic/configure.ac
@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
--- a/libatomic/configure
+++ b/libatomic/configure
@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi