You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download...

24 lines
833 B

--- a/ext/testbm.cmake
+++ b/ext/testbm.cmake
@@ -1,4 +1,2 @@
# these are used both for testing and benchmarking
-c4_require_subproject(c4fs REMOTE
- GIT_REPOSITORY https://github.com/biojppm/c4fs
- GIT_TAG master)
+c4_require_subproject(c4fs SUBDIRECTORY ext/c4fs)
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -103,10 +103,5 @@
- c4_require_subproject(c4log REMOTE
- GIT_REPOSITORY https://github.com/biojppm/c4log
- GIT_TAG master)
+ c4_require_subproject(c4log SUBDIRECTORY ../ext/c4log)
- set(tsdir ${ed}/yaml-test-suite)
- c4_download_remote_proj(yaml-test-suite tsdir
- GIT_REPOSITORY https://github.com/yaml/yaml-test-suite
- GIT_TAG bcd49a2d4919c1b1ac3b9d6e5ebe6b140b5089e3)
+ set(tsdir ${CMAKE_SOURCE_DIR}/ext/yaml-test-suite)
set(suite_dir ${tsdir}/src)