You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ada/gnatcoll/files/gnatcoll-2016-gentoo.patch

149 lines
5.5 KiB

--- a/Makefile 2017-01-20 19:39:07.131398270 +0100
+++ b/Makefile 2017-01-20 19:42:30.088728844 +0100
@@ -34,19 +36,19 @@
@${RM} src/gnatcoll-atomic.adb
@echo "====== Building $(@F) libraries ======"
- ${GPRBUILD} ${GPRBLD_OPTS} -Pgnatcoll_full
+ ${GPRBUILD} ${GPRBLD_OPTS} -Pgnatcoll_full -v -cargs ${ADAFLAGS}
@# Need to build libgnatcoll_gtk separately, because its project files
@# requires gtkada.gpr, which might not exist on the machine.
ifeq (${WITH_GTK},yes)
- ${GPRBUILD} ${GPRBLD_OPTS} -Psrc/gnatcoll_gtk
+ ${GPRBUILD} ${GPRBLD_OPTS} -Psrc/gnatcoll_gtk -v -cargs ${ADAFLAGS}
endif
@# Build the tools (the list is the project\'s Main attribute)
@# They are not build as part of the above because only the Main from
@# gnatcoll_full.gpr are build. We could use aggregate projects to
@# speed things up.
- ${GPRBUILD} ${GPRBLD_OPTS} -q -Psrc/gnatcoll_tools
+ ${GPRBUILD} ${GPRBLD_OPTS} -q -Psrc/gnatcoll_tools -v -cargs ${ADAFLAGS}
#######################################################################
# install
--- a/src/gnatcoll_sqlite.gpr 2017-01-07 09:00:17.146448202 +0100
+++ b/src/gnatcoll_sqlite.gpr 2017-01-07 09:00:44.884885281 +0100
@@ -60,7 +60,7 @@
-- force full optimization for sqlite, we do not debug it
-- in any case.
- "-O3") & Gnatcoll_Shared.Sqlite_Switches;
+ "-O3", "-fPIC") & Gnatcoll_Shared.Sqlite_Switches;
end case;
end Compiler;
--- a/src/gnatcoll_python.gpr.in 2017-01-07 09:12:30.490399897 +0100
+++ b/src/gnatcoll_python.gpr.in 2017-01-07 09:12:53.111976591 +0100
@@ -30,7 +30,7 @@
GnatColl_Shared.Compiler'Switches ("Ada");
for Switches ("C") use
- ("-g", "-O2") & GnatColl_Shared.Python_Cflags;
+ ("-g", "-O2", "-fPIC") & GnatColl_Shared.Python_Cflags;
end Compiler;
package Linker is
--- a/gnatcoll_shared.gpr.in 2017-01-20 19:50:03.222808656 +0100
+++ b/gnatcoll_shared.gpr.in 2017-01-20 19:50:28.200399274 +0100
@@ -13,7 +13,7 @@
type Yes_No is ("yes", "no");
Gtk : Yes_No := External ("GTK", "@WITH_GTK@");
- Python : Yes_No := External ("PYTHON", "@WITH_PYTHON@");
+ Python : Yes_No := "@WITH_PYTHON@";
Syslog : Yes_No := External ("SYSLOG", "@WITH_SYSLOG@");
Postgres : Yes_No := External ("POSTGRES", "@WITH_POSTGRES@");
type Sqlite_Inclusion is ("yes", "no", "embedded");
@@ -67,7 +67,7 @@
when "Production" =>
for Switches ("Ada") use ("-O2", "-gnatn", "-gnatws");
- for Switches ("C") use ("-O2", "-Wunreachable-code");
+ for Switches ("C") use ("-O2", "-Wunreachable-code", "-fPIC");
end case;
case Syslog is
--- a/src/gnatcoll_gtk.gpr.in 2017-01-20 19:53:16.647607400 +0100
+++ b/src/gnatcoll_gtk.gpr.in 2017-01-20 19:53:57.302925708 +0100
@@ -63,7 +63,7 @@
for Switches ("Ada") use GnatColl_Shared.Compiler'Switches ("Ada");
for Switches ("C") use
- ("-g", "-O2")
+ ("-g", "-O2", "-fPIC")
& GnatColl_Shared.Python_Cflags
& GnatColl_Shared.Pygtk_Include
& GnatColl_Shared.PyGobject_Include
--- a/aclocal.m4 2017-04-06 08:25:14.796699365 +0200
+++ b/aclocal.m4 2017-04-06 08:25:36.622318016 +0200
@@ -45,7 +45,7 @@
cat > conftest.ada <<EOF
[$3]
EOF
- if AC_TRY_COMMAND([gnatchop -q conftest.ada && $1 $2 >/dev/null 2>conftest.out])
+ if AC_TRY_COMMAND([${GNATCHOP} -q conftest.ada && $1 $2 >/dev/null 2>conftest.out])
then
: Success
$4
@@ -68,7 +68,7 @@
AC_DEFUN(AM_HAS_INTRINSIC_SYNC_COUNTERS,
[
AC_MSG_CHECKING([whether platform supports atomic inc/dec])
- AM_TRY_ADA([gnatmake], [check.adb],
+ AM_TRY_ADA([${GNATMAKE}], [check.adb],
[
with Interfaces; use Interfaces;
procedure Check is
--- a/testsuite/json/__init__.py 2017-04-24 17:52:34.158513249 +0200
+++ b/testsuite/json/__init__.py 2017-04-24 17:52:52.636207017 +0200
@@ -21,7 +21,7 @@
@requires_not_aix # Storage_Error on that machine
@chdir("MB28-001")
def test_MB28_001(self):
- self.runexec(["python", "make_json.py"])
+ self.runexec(["python2.7", "make_json.py"])
self.gprbuild()
self.runexec("json_stack_test", "test.out")
--- a/testsuite/projects/__init__.py 2017-04-24 19:10:30.465246199 +0200
+++ b/testsuite/projects/__init__.py 2017-04-24 19:10:42.768035080 +0200
@@ -105,25 +105,6 @@
self.gprbuild("default.gpr")
self.runexec("main", "")
- @support.requires_not_windows
- @chdir("N918-040")
- def test_bareboard(self):
- self.create_fake_bb_compiler('install', 'arm-eabi', '6.1.0w', '3.4.6')
-
- # Make sure auto.cgpr is not deleted on exit
- try:
- os.unlink('auto.cgpr')
- except:
- pass
- self.gprbuild('main_prj', switches=['--autoconf=auto.cgpr'])
- m = re.search('for Target use "(.*?)"', open('auto.cgpr').read())
- target = m.group(1)
-
- def customFilter(actual):
- return actual.replace(target, "<native>")
-
- self.runexec(['sh', 'test.sh'], 'test.out', customFilter=customFilter)
-
@chdir("NB12-045")
def test_NB12_045(self):
# Test registering attribute in unknown package
--- a/src/tools/gnatcoll_db2ada.adb 2017-04-24 21:36:09.193973179 +0200
+++ b/src/tools/gnatcoll_db2ada.adb 2017-04-24 21:36:16.029858932 +0200
@@ -211,7 +211,7 @@
declare
Output : constant String := Get_Command_Output
- (Command => "python",
+ (Command => "python2.7",
Arguments => Args,
Input => "",
Status => Status'Access,