You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/portmidi/files/portmidi-217-r4-python.patch

50 lines
1.5 KiB

diff -Naur portmidi-a/pm_python/setup.py portmidi-b/pm_python/setup.py
--- portmidi-a/pm_python/setup.py 2010-09-26 15:32:44.000000000 -0400
+++ portmidi-b/pm_python/setup.py 2020-03-19 12:34:34.398365103 -0400
@@ -15,12 +15,10 @@
DESCRIPTION = open('README_PYTHON.txt').read()
-CHANGES = open('CHANGES.txt').read()
-TODO = open('TODO.txt').read()
EXTRAS = {}
-long_description = DESCRIPTION + CHANGES + TODO
+long_description = DESCRIPTION
#import sys
#if "checkdocs" in sys.argv:
# print long_description
@@ -142,7 +140,7 @@
if sys.platform == 'win32':
- print "Found Win32 platform"
+ print("Found Win32 platform")
EXTENSION = dict(
ext_modules=[
Extension("pyportmidi._pyportmidi", [os.path.join("pyportmidi", "_pyportmidi.pyx")],
@@ -154,7 +152,7 @@
]
)
elif sys.platform == 'darwin':
- print "Found darwin (OS X) platform"
+ print("Found darwin (OS X) platform")
library_dirs = ["/usr/local/lib"]
include_dirs = ["/usr/local/include"]
EXTENSION = dict(
@@ -169,11 +167,11 @@
]
)
else:
- print "Assuming Linux platform"
+ print("Assuming Linux platform")
EXTENSION = dict(
ext_modules=[
Extension("pyportmidi._pyportmidi", [os.path.join("pyportmidi", "_pyportmidi.pyx")],
- library_dirs=["./linux"],
+ include_dirs=["../pm_common", "../porttime"],
libraries = ["portmidi", "asound", "pthread"]
)
]