You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch

25 lines
779 B

diff -ruN /src/Makefile.am /tmp/src/Makefile.am
--- a/src/Makefile.am 2006-06-22 12:35:01.531885552 +0800
+++ b/src/Makefile.am 2006-06-22 12:31:44.000000000 +0800
@@ -5,6 +5,8 @@
zhcon_LDADD = display/libdisplay.a
+zhcon_CPPFLAGS = -DSYSCONF_DIR=\"${sysconfdir}\"
+
SUBDIRS = display
install-exec-local:
diff -ruN src/zhcon.cpp /tmp/src/zhcon.cpp
--- a/src/zhcon.cpp 2006-06-22 12:35:01.398905768 +0800
+++ b/src/zhcon.cpp 2006-06-22 12:32:41.000000000 +0800
@@ -123,7 +123,7 @@
string cfgfile = getenv("HOME");
cfgfile += "/.zhconrc";
if (access(cfgfile.c_str(), R_OK) != 0)
- cfgfile = PREFIX "/etc/zhcon.conf";
+ cfgfile = SYSCONF_DIR"/zhcon.conf";
//for debug,a pause enable us to attach zhcon's pid in gdb
//char c;cin>>c;