You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/mujs/files/mujs-0_p20150202-Makefile.p...

29 lines
593 B

--- mujs-0_p20150202/Makefile
+++ mujs-0_p20150202/Makefile
@@ -2,23 +2,17 @@
HDRS := $(wildcard js*.h mujs.h utf.h regex.h)
OBJS := $(SRCS:%.c=build/%.o)
-prefix ?= /usr/local
+prefix ?= /usr
bindir ?= $(prefix)/bin
incdir ?= $(prefix)/include
libdir ?= $(prefix)/lib
-CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
ifeq "$(CC)" "clang"
CFLAGS += -Wunreachable-code
endif
-ifeq "$(build)" "debug"
-CFLAGS += -g
-else
-CFLAGS += -O2
-endif
-
default: build build/mujs build/mujsone
debug: