You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libnet/files/libnet-1.2-_SOURCE.patch

21 lines
735 B

--- a/configure.ac
+++ b/configure.ac
@@ -157,14 +157,14 @@
case "$target_os" in
*linux*)
- AC_DEFINE(_BSD_SOURCE, 1,
+ AC_DEFINE(_DEFAULT_SOURCE, 1,
[Define as necessary to "unhide" header symbols.])
- AC_DEFINE(__BSD_SOURCE, 1,
+ AC_DEFINE(__DEFAULT_SOURCE, 1,
[Define as necessary to "unhide" header symbols.])
AC_DEFINE(__FAVOR_BSD, 1,
[Define if we should favor the BSD APIs when possible in Linux.])
- LIBNET_CONFIG_DEFINES="-D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD"
+ LIBNET_CONFIG_DEFINES="-D_DEFAULT_SOURCE -D__DEFAULT_SOURCE -D__FAVOR_BSD"
AC_CHECK_HEADERS(net/ethernet.h, \
LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DHAVE_NET_ETHERNET_H")
;;