You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/jq/files/jq-1.7-runpath.patch

18 lines
572 B

diff --git a/configure.ac b/configure.ac
index 0441d4a..8f1aa23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,4 +283,11 @@ AC_SUBST([BUNDLER], ["$bundle_cmd"])
AC_CONFIG_MACRO_DIR([config/m4])
AC_CONFIG_FILES([Makefile libjq.pc])
AC_OUTPUT
-
+AC_ARG_ENABLE([rpathhack],
+ [AC_HELP_STRING([--enable-rpathhack], [patch libtool to remove RPATH])],
+ [
+AC_MSG_RESULT([patching libtool to fix rpath])
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ ],
+ [])