You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/rocs/files/rocs-15.12.3-doctools-optio...

30 lines
846 B

commit c4d77a5348fcf18aff734ccff13dcc87582a35be
Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
Date: Tue Mar 8 19:34:32 2016 +0100
Make KF5DocTools really optional
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc71ba0..8e2c4e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,6 @@ find_package(KF5 5.15 REQUIRED COMPONENTS
CoreAddons
Crash
Declarative
- DocTools
I18n
ItemViews
TextEditor
@@ -80,7 +79,9 @@ remove_definitions(-DQT_NO_KEYWORDS)
ecm_optional_add_subdirectory(libgraphtheory)
ecm_optional_add_subdirectory(src)
ecm_optional_add_subdirectory(icons)
-ecm_optional_add_subdirectory(doc)
+if(KF5DocTools_FOUND)
+ ecm_optional_add_subdirectory(doc)
+endif()
set_package_info(Boost "Boost C++ Libraries" "http://www.boost.org")
feature_summary(WHAT ALL)