You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch

33 lines
929 B

Description: Fix code to compile with wxwidgets 3.0
Drops support for wx < 2.7, which is just not relevant now. And in fact
configure.ac checks for at least 2.8.0.
Author: Olly Betts <olly@survex.com>
Last-Update: 2014-03-07
--- xchm-1.23.orig/src/chmframe.cpp
+++ xchm-1.23/src/chmframe.cpp
@@ -265,11 +265,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
enu.EnumerateFacenames();
_normalFonts = new wxArrayString;
-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
*_normalFonts = enu.GetFacenames();
-#else
- *_normalFonts = *enu.GetFacenames();
-#endif
_normalFonts->Sort();
}
@@ -278,11 +274,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
enu.EnumerateFacenames(wxFONTENCODING_SYSTEM, TRUE);
_fixedFonts = new wxArrayString;
-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
*_fixedFonts = enu.GetFacenames();
-#else
- *_fixedFonts = *enu.GetFacenames();
-#endif
_fixedFonts->Sort();
}