You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/grpcio-tools/files/setup.py-respect-cc.patch

15 lines
636 B

--- a/setup.py 2020-06-08 00:11:23.457959701 -0700
+++ b/setup.py 2020-06-08 00:11:54.384652323 -0700
@@ -68,9 +68,10 @@
def check_linker_need_libatomic():
"""Test if linker on system needs libatomic."""
+ cc = os.environ.get('CC', 'cc')
code_test = (b'#include <atomic>\n' +
b'int main() { return std::atomic<int64_t>{}; }')
- cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'],
+ cc_test = subprocess.Popen([cc, '-x', 'c++', '-std=c++11', '-'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)