You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/darktable/files/darktable-3.0.2_jsonschema-...

20 lines
729 B

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,15 +319,7 @@
message(STATUS "Test-compilation of OpenCL programs is disabled.")
endif()
-# we need jsonschema to check noiseprofiles.json
-find_program(jsonschema_BIN jsonschema)
-if(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
- message(STATUS "Missing jsonschema, problems in noiseprofiles.json might go unnoticed")
- set(VALIDATE_JSON 0)
-else(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
- message(STATUS "Found jsonschema")
- set(VALIDATE_JSON 1)
-endif(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+set(VALIDATE_JSON 0)
# we need an xslt interpreter to generate preferences_gen.h and darktablerc
find_program(Xsltproc_BIN xsltproc)