You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/gst-plugins-ugly/files/gst-plugins-ugly-1.14.3-mak...

18 lines
540 B

--- a/common/glib-gen.mak
+++ b/common/glib-gen.mak
@@ -1,11 +1,13 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_enum_prefix=gst_color_balance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
%-marshal.h: %-marshal.list