You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/jaaa/files/jaaa-0.9.2-Makefile.patch

17 lines
536 B

diff --git a/source/Makefile b/source/Makefile
index fec867e..0c769f6 100644
--- a/source/Makefile
+++ b/source/Makefile
@@ -23,9 +23,8 @@ BINDIR ?= $(PREFIX)/bin
VERSION = 0.9.2
CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(PREFIX)\" -I.
-CPPFLAGS += $(shell pkgconf --cflags freetype2)
-CXXFLAGS += -O2 -Wall
-CXXFLAGS += -march=native
+CPPFLAGS += $(shell pkg-config --cflags freetype2)
+CXXFLAGS += -Wall
LDLIBS += -lzita-alsa-pcmi -lclthreads -lclxclient -lasound -lpthread \
-lfftw3f -ljack -lXft -lX11 -lrt